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Ex.No:1-a).   VOWEL CHECKING  
 

Aim: Write aVB.Net program to accept any character from keyboard and display whether it is  

vowel or not. 

 

Procedure:   

1. Click Start→Programs→MicrosoftVisualStudio 2005 → MicrosoftVisualStudio 2005  

2. Select File →New → Project → WindowsApplication. 

3. Place the label, textbox and button in the window. 

4. Write the code in click event of Button1 

5. Run the application by pressing F5 key or by clicking debug button. 

 

 

Control Name Property Setting 

Label1 Text Enter the character 

Label2 Text Result 

Text1 -- -- 

Text2 -- -- 

Button1 Text Check 

Button2 Text Clear 

 

Program: 

 

Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles 

Button1.Click 

        Dim c As Char 

        c = UCase(TextBox1.Text) 

        If c = "A" Or c = "E" Or c = "I" Or c = "O" Or c = "U" Then 

            TextBox2.Text = "VOWEL" 

        Else 

            TextBox2.Text = "NOT VOWEL" 

        End If 

    End Sub 

 

    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles 

Button2.Click 

        TextBox1.Text = "" 

        TextBox2.Text = "" 

    End Sub 

End Class 
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Sample Output: 

 
 

Result: Thus the program for vowel checking was executed and the output was verified. 
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Ex.No:1-b)   AREA OF CIRCLE 

Aim:Write a VB .NET program to find the area of circle using console application. 

 

Procedure: 

1.Click Start→Programs→MicrosoftVisualStudio 2005 → MicrosoftVisualStudio 2005  

2.Select File → New→ Project → Consoleapplication. 

3.Open the Console application. 

4.Write the code in the editor window. 

5.Run the application by F5 key or pressing debug button. 

 

Program: 

Module Module1 

    Sub Main() 

        Dim a, r As Double 

        Console.Write("Enter the radius:") 

        r = Console.ReadLine() 

        a = 3.14 * r * r 

        Console.WriteLine("Area of Circle:{0}", a) 

    End Sub 

End Module 

 

 
 

Result: Thus the program for case conversion was executed and the output was verified. 
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Ex.No:2   REVERSE A GIVEN NUMBER USING WINDOWS APPLICATION 

Aim: Write a VB .NET program to reverse the given set of numbers using windows application. 

 

Procedure: 

1. Click Start→Programs→MicrosoftVisualStudio 2005 → MicrosoftVisualStudio 2005  

2. Select File → New→ Project → Windows Application. 

3. Place the label, textbox and button in the window. 

4. Write the code in click event of Button1 and Button2 

5. Run the application by pressing F5 key or by clicking debug button. 

 

 

Control Name Property Setting 

Label1 Text Reverse a Given Number 

Label2 Text Enter the Number 

Label3 Text Reversed Number 

Text1 -- -- 

Text2 -- -- 

Button1 Text Reverse 

Button2 Text Clear 

 

 

Form Design: 
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Form Layout: 

 

 
 

Program: 

 

Public Class Form1 

    Dim r As Integer 

    Public Function Reverse(ByVal rn As Integer) 

        Dim numbers = Val(TextBox1.Text) 

        Dim result As Integer 

        While numbers > 0 

            rn = numbers Mod 10 

            result = result * 10 + rn 

            numbers = numbers \ 10 

        End While 

        Reverse = result 

    End Function 

    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles 

Button1.Click 

        TextBox2.Text = Reverse(r) 

    End Sub 

 

    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles 

Button2.Click 

        TextBox1.Text = "" 

        TextBox2.Text = "" 

    End Sub 

End Class 
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Sample Output: 

 

 
 

Result: Thus the program was executed and the output was verified. 
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Ex.No:4  FACTORIAL OF THE GIVEN NUMBER 

Aim: Write a VB .NET program to find the factorial of the given number. 

 

Procedure: 

1. Click Start→Programs→MicrosoftVisualStudio 2005 → MicrosoftVisualStudio 2005  

2. Select File → New→ Project → Windowsapplication. 

3. Place the label, textbox and button in the window. 

4. Write the code in click event of Button1. 

5. Run the application by pressing F5 key or by clicking debug button. 

 

Control Name Property Setting 

Label1 Text Factorial of the given 

number 

Label2 Text Enter the Number 

Text1 -- -- 

Button1 Text Find 

 

Form Design: 
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Form Layout: 

 

 
 

Program: 

 

Public Class Form1 

    Function fact(ByVal a As Integer) As Integer 

        Dim f As Integer 

        f = 1 

        For i = 1 To a 

            f = f * i 

        Next 

        fact = f 

    End Function 

    Private Sub Button1_Click(sender As Object, e As EventArgs) Handles Button1.Click 

        Dim n, r As Integer 

        n = TextBox1.Text 

        r = fact(n) 

        MsgBox("Factorial is :" & r, vbInformation, "Factorial") 

    End Sub 

End Class 

 

Sample Output: 

 

 
 

Result: Thus the program was executed and the output was verified. 
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Ex.No:6 ILLUSTRATE THE USE MSGBOX AND INPUTBOX FUNCTION 

Aim: Write a VB .NET program using MsgBox and InputBox function. 

 

Procedure: 

1. Click Start→Programs→MicrosoftVisualStudio 2005 → MicrosoftVisualStudio 2005  

2. Select File → New→ Project → Windowsapplication. 

3. Place the label and button in the window. 

4. Write the code in click event of Button1. 

5. Run the application by pressing F5 key or by clicking debug button. 

 

 

Control Name Property Setting 

Label1 Text Program using MsgBox and InputBox Function 

Button1 Text Click 

 

Form Design: 

 
 

 

Form Layout: 

 

 
 

Program: 

 

Public Class Form1 

    Private Sub Button1_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) 
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        Dim a, b, c As Integer 

        a = InputBox("Enter the a value") 

        b = InputBox("Enter the b value") 

        c = a + b 

        MsgBox("The Addition of two numbers is" & c, vbInformation, "ADDITION") 

    End Sub 

End Class 

 

Sample Output: 

 

     
 

 
 

Result: Thus the program was executed and the output was verified. 
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Ex.No 7    ILLUSTRATE THE USE OF CHECKBOX, RADIO BUTTON AND LISTBOX 

 

Aim: To write the VB.Net program to illustrate the use of Checkbox, Radio button and List Box. 

 

Procedure: 

 

1. Click Start→Programs→MicrosoftVisualStudio 2005 → MicrosoftVisualStudio 2005  

2. Select File → New→ Project → Windowsapplication. 

3. Place the label, button, panel, checkbox, radio button and list box in the window. 

4. Write the code in click event of Button1 and Button2 

5. Run the application by pressing F5 key or by clicking debug button. 

 

Control Name Property Setting 

Label1 Text Program using Checkbox, Radio button and List box 

Label2 Text Select your favorite subject 

Label3 Text  

Label4 Text Select the number 

Label5 Text Select the mode of operation 

Ckeckbox1 Text English 

Checkbox2 Text Tamil 

Checkbox3 Text Maths 

Checkbox4 Text Science 

Panel   

Listbox1  1,2,3,4,5,6,7,8,9,10 

Radiobutton1 Text Square 

Radiobutton2 Text Cube 

Button1 Text Select 

Button2 Text Click Me 

 

 

Form Design 
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Form Layout 

 

 
 

 

Program: 

 

Public Class Form1 

    Dim num As Integer 

    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles 

Button1.Click 

        Label3.Text = "" 

        For Each c1 As CheckBox In Panel1.Controls 

            If c1.Checked Then 

                Label3.Text &= c1.Text & vbCrLf 

            End If 

        Next 

        MsgBox("Can i ask question from maths") 

    End Sub 

 

    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles 

Button2.Click 

        num = ListBox1.SelectedItem 

        If RadioButton1.Checked = True Then 

            MsgBox(num * num) 

        Else 

            MsgBox(num * num * num) 

        End If 

    End Sub 

End Class 

 

Sample Output 
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Result: Thus the Program was successfully executed 
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Ex. No: 8   STOPWATCH TIMER CONTROL 

 

Aim: To write a VB.NET application to implement the timer control 

 

Procedure: 

1. Click Start→Programs→MicrosoftVisualStudio 2005 → MicrosoftVisualStudio 2005  

2. Select File → New→ Project → Windowsapplication. 

3. Open the Windows application. 

4. Place the Timer control, Label box and Buttons from tool box.  

5. Write the code in click event of Button1 and Button2 

6. Run the application by pressing F5 key or by clicking debug button. 

 

Control Name Property Setting 

Label1 Text Stopwatch Timer control 

Label2 Text  

Label3 Text  

Label4 Text  

Timer Control Interval 100 

Button1 Text Start 

Button2 Text Pause 

Button3 Text Reset 

 

Form Layout: 
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Form Design: 

 

 
 

 

Program: 

 

Public Class Form1 

    Dim second As Integer = 0 

    Dim minute As Integer = 0 

    Dim hours As Integer = 0 

    Private Sub Timer1_Tick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles 

Timer1.Tick 

        second = second + 1 

        Label2.Text = second 

        If (second = 60) Then 

            minute = minute + 1 

            second = 0 

            Label3.Text = minute 

        End If 

        If (minute = 60) Then 

            hours = hours + 1 

            second = 0 

            minute = 0 

            Label3.Text = minute 

            Label4.Text = hours 

        End If 

    End Sub 

 

    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles 

Button1.Click 

        Timer1.Start() 

    End Sub 

 

    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles 

Button2.Click 

        Timer1.Stop() 

    End Sub 

 

    Private Sub Button3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles 

Button3.Click 

        Timer1.Stop() 
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        minute = 0 

        second = 0 

        hours = 0 

        Label2.Text = "00" 

        Label3.Text = "00" 

        Label4.Text = "00" 

    End Sub 

End Class 

 

Sample Output 

 

 
 

Result : Thus the program was successfully executed 
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Ex. No: 9   Menu Driven 

 

Aim: To write a VB.NET application to implement the text editor using Menu control 

 

Procedure: 

1. Click Start→Programs→MicrosoftVisualStudio 2005 → MicrosoftVisualStudio 2005  

2. Select File → New→ Project → Windowsapplication. 

3. Open the Windows application. 

4. Main menu is constructed with number of sub menus named as close, save, cut, copy, paste.  

6. Drag and place a RichTextBox, Save File Dialog Controls in the form.  

7. Insert the source code for appropriate menu items and finally run the application.  

 

Control Name Property Setting 

MenuStrip  - - 

SaveFileDialog - - 

 

 

Form Design 

 
 

Program 

 

Public Class Form1 

    Private Sub SaveToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As 

System.EventArgs) Handles SaveToolStripMenuItem.Click 

        SaveFileDialog1.Filter = "TXT Files (*.txt*)|*.txt" 

        If SaveFileDialog1.ShowDialog = Windows.Forms.DialogResult.OK _ 

      Then 

            My.Computer.FileSystem.WriteAllText _ 
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            (SaveFileDialog1.FileName, RichTextBox1.Text, True) 

        End If 

    End Sub 

    Private Sub CloseToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As 

System.EventArgs) Handles CloseToolStripMenuItem.Click 

        End 

    End Sub 

 

    Private Sub CutToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As 

System.EventArgs) Handles CutToolStripMenuItem.Click 

        RichTextBox1.Cut() 

    End Sub 

 

    Private Sub CopyToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As 

System.EventArgs) Handles CopyToolStripMenuItem.Click 

        RichTextBox1.Copy() 

    End Sub 

 

    Private Sub PasteToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As 

System.EventArgs) Handles PasteToolStripMenuItem.Click 

        RichTextBox1.Paste() 

    End Sub 

End Class 

 

Result: Thus the program was successfully executed. 
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Ex. No: 10   Tree View 

 

Aim: To write a VB.NET application to implement the concept of Tree View Control and List View 

Control 

 

Tree View 

 

Procedure: 

1. Click Start→Programs→MicrosoftVisualStudio 2005 → MicrosoftVisualStudio 2005  

2. Select File → New→ Project → Windowsapplication. 

3. Open the Windows application. 

4. Drag and place a Tree View, 3 Buttons in the form  

5. Insert the source code for appropriate control and finally run the application.  

 

 

 

Control Name Property Setting 

TreeView - - 

Button1 Text Add Root Node 

Button2 Text Add Shapes 

Button3 Text Add Colors 

 

Form Layout 
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Form Design 

 

 
 

Program 

 

Public Class Form1 

    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles 

Button1.Click 

        TreeView1.Nodes.Add("Shapes") 

        TreeView1.Nodes.Add("Colors") 

    End Sub 

 

    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles 

Button2.Click 

        Dim snode As TreeNode 

        snode = TreeView1.Nodes(0) 

        snode.Nodes.Add("Square") 

        snode.Nodes.Add("Triangle") 

        snode.Nodes.Add("Circle") 

    End Sub 

 

    Private Sub Button3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles 

Button3.Click 

        Dim cnode As TreeNode 

        cnode = TreeView1.Nodes(1) 

        cnode.Nodes.Add("Pink") 

        cnode.Nodes.Add("Maroon") 

        cnode.Nodes.Add("Teal") 

    End Sub 

End Class 

 

ListView 

 

Procedure: 

1. Click Start→Programs→MicrosoftVisualStudio 2005 → MicrosoftVisualStudio 2005  

2. Select File → New→ Project → Windowsapplication. 

3. Open the Windows application. 

4. Drag and place a List View, 3 TextBoxes and 3 Labels and 1 Button control in the form  

5. Insert the source code for appropriate controls and finally run the application.  
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Control Name Property Setting 

ListView - - 

Label1 Text Name 

Label2 Text Roll Number 

Label3 Text Class 

TextBox1 - - 

TextBox2 - - 

TextBox3 - - 

Button1 Text Save 

 

Form Layout 

 

 
 

Form Design 

 

 
 

Program: 
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Public Class Form1 

        Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) 

Handles Button1.Click 

        Dim str(4) As String 

        Dim itm As ListViewItem 

        str(0) = TextBox1.Text  'Accept value from the user.   

        str(1) = TextBox2.Text 

        str(2) = TextBox3.Text 

        itm = New ListViewItem(str) 

        ListView1.Items.Add(itm) 'Add the items into the ListView   

    End Sub 

    Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles 

MyBase.Load 

        ListView1.View = View.Details  ' Display the List in details   

        ListView1.GridLines = True   ' Set the Grid lines    

        ListView1.Columns.Add("Student Name", 100, HorizontalAlignment.Left) ' set the name of column   

        ListView1.Columns.Add("Roll Number", 100, HorizontalAlignment.Left) ' set the name of column   

        ListView1.Columns.Add("Class", 100, HorizontalAlignment.Left) ' set the name of column   

        ListView1.BackColor = Color.LightSkyBlue 

    End Sub 

End Class 

 

Result : Thus the program was successfully executed. 
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Ex. No: 11   Combo Box 

 

Aim: To write a VB.NET application to implement the concept of combo box using class 

 

Procedure: 

1. Click Start→Programs→MicrosoftVisualStudio 2005 → MicrosoftVisualStudio 2005  

2. Select File → New→ Project → Windowsapplication. 

3. Open the Windows application. 

4. Drag and place a 5 Combo boxes and 1 Button control in the form.  

5. Insert the source code for appropriate controls and finally run the application.  

 

 

Form Layout 

 

 
 

Form Design 

 

 
 

Public Class Form1 

    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles 

Button1.Click 

        Dim average As Single 

        average = (Val(ComboBox1.Text) + Val(ComboBox2.Text) + Val(ComboBox3.Text) + 

Val(ComboBox4.Text) + Val(ComboBox5.Text)) / 5 

        MsgBox("Average = " & average) 

    End Sub 
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    Private Sub Form1_Load (ByVal sender As System.Object, ByVal e As System.EventArgs) Handles 

MyBase.Load 

        ComboBox1.Items.Add(5) 

        ComboBox1.Items.Add(8) 

        ComboBox1.Items.Add(12) 

        ComboBox2.Items.Add(20) 

        ComboBox2.Items.Add(32) 

        ComboBox2.Items.Add(6) 

        ComboBox3.Items.Add(11) 

        ComboBox3.Items.Add(17) 

        ComboBox3.Items.Add(24) 

        ComboBox4.Items.Add(36) 

        ComboBox4.Items.Add(100) 

        ComboBox4.Items.Add(34) 

        ComboBox5.Items.Add(20) 

        ComboBox5.Items.Add(90) 

        ComboBox5.Items.Add(23) 

    End Sub 

End Class 

 

Result : Thus the program was successfully executed. 
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Ex. No: 12  Store the Student Details 

 

Aim: To develop a VB.Net application  for database connectivity using MS-Access 

Procedure: 

1. Click Start→Programs→MicrosoftVisualStudio 20015 → MicrosoftVisualStudio 2005  

2. Select File → New→ Project → Windowsapplication. 

3. Open the Windows application. 

4. Drag and place a 5 labels ,5 text box and 1 buttons in the form.  

5. Insert the source code for appropriate Controls and finally run the application. 

 

Control Name Property Setting 

Label1 Text Name 

Label2 Text Roll Number 

Label3 Text Register Number 

Label4 Text Class 

Label5 Text Phone Number 

Button1 Text Store 

 

 

Form Design: 

 

 
 

 

 

 

 

Program 

 

Imports System.Data.OleDb 

Imports System.Data 

Public Class Form3 

    Dim cmd As OleDbCommand 

    Dim da As OleDbDataAdapter 

    Dim dr As OleDbDataReader 

    Dim variable As String 
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    Dim con As New OleDbConnection("Provider=Microsoft.Jet.OLEDB.4.0;Data 

Source=C:\Users\user\Documents\benazirbutto\student1.mdb") 

    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles 

Button1.Click 

        con.Open() 

        cmd = New OleDbCommand("insert into student1 values(‘" & TextBox1.Text & "’,” & 

TextBox2.Text &”," & TextBox3.Text & ",’”& TextBox4.Text&”’ , “& TextBox5.Text&”)", con) 

        cmd.ExecuteNonQuery() 

        MsgBox("Records inserted successfully") 

        con.Close() 

        TextBox1.Text = "" 

        TextBox2.Text = "" 

        TextBox3.Text = "" 

    End Sub 

 

Result : Thus the Program was executed Succesfully. 
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Ex. No: 13  Insert and Delete Operation 

 

Aim: To develop a VB.Net application  for database connectivity using MS-Access 

Procedure: 

1. Click Start→Programs→MicrosoftVisualStudio 20015 → MicrosoftVisualStudio 2005  

2. Select File → New→ Project → Windowsapplication. 

3. Open the Windows application. 

4. Drag and place a 3 labels ,3 text box and 2 buttons in the form.  

5. Insert the source code for appropriate Controls and finally run the application. 

 

  

Control Name Property Setting 

Label1 Text Name 

Label2 Text Roll Number 

Label3 Text Class 

Textbox1 -- -- 

Textbox2 -- -- 

Textbox3 -- -- 

Button1 Text Insert 

Button2 Text Delete 

 

 

Form Layout 
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Form Design 

 
 

Program 

 

Imports System.Data.OleDb 

Imports System.Data 

Public Class Form3 

    Dim cmd As OleDbCommand 

    Dim da As OleDbDataAdapter 

    Dim dr As OleDbDataReader 

    Dim variable As String 

    Dim con As New OleDbConnection("Provider=Microsoft.Jet.OLEDB.4.0;Data 

Source=C:\Users\user\Documents\benazirbutto\student1.mdb") 

    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles 

Button1.Click 

        con.Open() 

        cmd = New OleDbCommand("insert into student1 values(‘" & TextBox1.Text & "’," & 

TextBox2.Text & “,'" & TextBox3.Text & "')", con) 

        cmd.ExecuteNonQuery() 

        MsgBox("Records inserted successfully") 

        con.Close() 

        TextBox1.Text = "" 

        TextBox2.Text = "" 

        TextBox3.Text = "" 

    End Sub 

Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles 

Button2.Click 

        con.Open() 

        cmd = New OleDbCommand("delete from student1 where rollno=" & TextBox1.Text, con) 

        cmd.ExecuteNonQuery() 

        con.Close() 

        MsgBox("record deleted successfully", MsgBoxStyle.Information) 

    End Sub 

 

Result : Thus the program was executed successfully. 

 


